Share
Issue:                  Serv-U FTP Server 15.1.7 Persistent Cross Site Scripting Vulnerability

CVE:                    CVE-2019-13182

Security researcher:    Richard Tan @ The Missing Link Security

Product name:           Serv-U FTP Server

Product version:        Tested on 15.1.7

Fixed in:               Serv-U 15.1.7 Hotfix 2

 

# Overview

The application is vulnerable to a stored cross-site scripting
vulnerability.The user's "Full Name" field and "HTTP Login Title Text" field
lacked input validation allowing Javascript code to be inserted and executed
in the context the user's browser session either when the victim logs to the
web client or browses to the Serv-U server login page.

A privilege user could manipulate the affected parameter on an existing
user's account so that Javascript is executed on the client's browser when
the victim logs into his account.

For example, a successful XSS attack could result in the attacker
redirecting the user to a phishing/malicious site or performing actions as
the victim on the Serv-U application.

 

**Injection Point in user properties**

* Full Name

* HTTP Login Title Text

 

# Proof of concept

1)      Login as a user that has privileges to create or modify users.

2)      Create a new user and add the following payload into the "Fullname"
parameter.
<script>window.location.replace("http://www.example.com");</script>

3)        Login as the victim user and observe the user being redirected to
www.example.com <http://www.example.com>  when accessing the web client.
Note that exploiting the "HTTP Login Title Text" field means that the
Javascript payload will be executed when any user browses to the Serv-U
login page.


#  0day.today [2019-12-17]  #