Share
## https://sploitus.com/exploit?id=88F6B58C-F169-5CE1-B1F8-EC22EA6169CA
# CVE-2022-23121-RCE
NETATALK-AFP-PROTO RCE :| This CVE-2022-23121 allows remote malicious users to execute arbitrary code on affected installations of Netatalk. Authentication is not required to exploit this vulnerability. The specific flaw exists within the parse_entries function. The issue results from the lack of proper error handling when parsing AppleDouble entries. An attacker can leverage this vulnerability to execute code in the context of root.
CVE score: 9.8/10 critical

# writeup:
https://research.nccgroup.com/2022/03/24/remote-code-execution-on-western-digital-pr4100-nas-cve-2022-23121/

# prof details:
the script is supported ip list/single ip with multi threaded capability.
![rce](rce.gif)

# there are ~100k netatalk installations exposed to internet according to shodan

![shodan](shodan.png)

# only three copies are available for now
https://satoshidisk.com/pay/CFPqTi