Share
## https://sploitus.com/exploit?id=A2578557-0664-501F-9147-E6C33286A9ED
# CVE-2023-22518
Checker for CVE-2023-22518 vulnerability on Confluence

## Description
This script checks for the CVE-2023-22518 vulnerability in Atlassian Confluence Data Center and Server instances. It sends a specially crafted POST request to a specified instance and analyzes the HTTP status code to determine potential vulnerability.

## Usage
1. Install the requirements: `pip install -r requirements.txt`
2. Run the script with the `-i` flag followed by the URL of the Confluence instance: `python CVE-2023-22518.py -i http://your-confluence-instance.com`
3. Based on server response, it will show a message indicating if it's potentially vulnerable or not.

## Legal Disclaimer
This script is for educational and authorized testing purposes only. Ensure you have explicit permission to test the target instance. Unauthorized access to computer systems is illegal and punishable by law. Use at your own risk and responsibility.