# CVE-2024-0757 (Exploit)
## Description
The Insert or Embed Articulate Content into WordPress plugin for WordPress is vulnerable to arbitrary file uploads through insecure file uploads in a zip archive in all versions up to, and including, 4.3000000023. This makes it possible for unauthenticated attackers to upload zip files containing phar files on the affected site's server which may make remote code execution possible.

> CVSS:	**8.8 (High)** [CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H]  
> Software Type:	**Plugin**  
> Software Slug:	**insert-or-embed-articulate-content-into-wordpress**  
> Affected Version:	**<= 4.3000000023**  

## Exploit
1. Clone the exploit
``` bash
  git clone && cd CVE-2024-0757-Exploit
2. Install requirements
``` bash
  pip install -r requirements.txt
3. Run exploit
``` bash
4. Browse to given url and click on **Go to shell page**
5. You have a shell :)

## PoC video