Share
## https://sploitus.com/exploit?id=PACKETSTORM:166632
Tittle:  
WordPress Plugin WP Downgrade < 1.2.3 - Admin + Stored Cross-Site Scripting  
  
References:  
CVE-2022-1001  
  
Author:  
Taurus Omar   
  
Description:  
The plugin only perform client side validation of its "WordPress Target Version" settings, but does not sanitise and escape it server side, allowing high privilege users such as admin to perform Cross-Site attacks even when the unfiltered_html capability is disallowed.  
  
Affects Plugins:  
wp-downgrade - Fixed in version 1.2.3  
  
Proof of Concept:  
Access the settings of the plugin (/wp-admin/options-general.php?page=wp_downgrade) and remove the max length as well as pattern attribute on the "WordPress Target Version" settings field, then put the following payload in it and save: <script>alert(/XSS/)</script>   
  
Classification  
Type XSS   
OWASP top 10 A7: Cross-Site Scripting (XSS)  
CWE-79  
  
wpScan:  
https://wpscan.com/vulnerability/85582b4f-a40a-4394-9834-0c88c5dc57ba  
  
TracWordpress:  
https://plugins.trac.wordpress.org/changeset/2696091