Share
## https://sploitus.com/exploit?id=1405211A-94E2-5ECA-BF96-441D2FF564CB
# CVE-2022-1388-Exploit
Test and Exploit Scripts for CVE 2022-1388 (F5 Big-IP)

![alt text](https://github.com/thatonesecguy/CVE-2022-1388-Exploit/blob/main/ss.png)

`mass_check.py` will take a file input and check the hosts are vulnerable without exploiting them.

### Detection:

Scanning for `/mgmt/tm/util/bash` as an endpoint, likely to be in web server logs. Or if you have a F5 go patch it, the affected versions are shown below and the patch is available here https://support.f5.com/csp/article/K23605346

### Vulnerable Versions
- BIG-IP versions 16.1.0 to 16.1.2 (Patch released)
- BIG-IP versions 15.1.0 to 15.1.5 (Patch released)
- BIG-IP versions 14.1.0 to 14.1.4 (Patch released)
- BIG-IP versions 13.1.0 to 13.1.4 (Patch released)
- BIG-IP versions 12.1.0 to 12.1.6 (End of Support)
- BIG-IP versions 11.6.1 to 11.6.5 (End of Support)